does not work on centos with python 2.6