core bootstrap templates need to all support environments