Gem Package provider incompatible with rubygems 2.0